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Chapter Fourteen:
Character Generator

A picture may be worth a thousand words, but sometimes you need
words and graphics to explain who someone is, where an event occurs, or to
demonstrate a concept. You use the Character Generator (CG) to create text
and graphics in a flexible work environment where you can design with still
or moving video in the background. There is no guesswork when you place
text or graphic elements. 

This chapter introduces you to the CG interface. You will learn the
options for building text and shapes, and how to add color, outlines, and
shading. You also learn the different kinds of CG pages and how to work with
the layout of those pages.

Figure 14.1. The Character Generator
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INTERFACE
When you open the CG panel, the work area shows a blank grid. The

edges of the grid represent the safe video area, discussed next. The CG
opens in text mode by default. An I-beam sits at the upper left corner; this is
your cursor and the insert point for your CG entries. You can move the I-
beam anywhere on the display by clicking on it with your mouse and
dragging it around. Entering text on your screen is just a matter of typing
what you want from the keyboard.

SAFE AREA FOR CG
The safe area (Figure 14.2) gives you a guideline for placing action or text

so that it appears properly on a television monitor. The inner box represents
the safe title area where you should place text. The outer box is indicates
the edge of active video, which includes overscan. Halfway between the safe
title and active video is the safe action area. The region outside active video
is a paste board where you can place objects, but they will not appear on
output.

You want to be sure that viewers can easily read the text and graphics
that you create; areas within the safe area will appear on the television
screen, while areas outside of the safe area may be cropped out. You can
toggle off the safe area by clicking on the Safe Area button at the top right
of the panel. 
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Figure 14.2. The Safe Areas: the inner area is Safe Title and the outer area is Safe Action

TIDBIT

Not all televisions display the same; they use different tubes and different
frames at the edge of the screen. Because of this variation from set to
set, video professionals must rely on a dual-bordered safe area.The inner
boundary is the safe title area where on-screen text should remain, so it
won't be cut off the edge of the screen.The outer boundary delimits
active video, and the safe action area falls half way between the two
boundaries.

TVISION AND CG
When you click on the TVision button, the CG loads the current image or

video showing in ToasterVision. Thus if you want to see the source on the
Preview bus of the Switcher, you must choose Prev on ToasterVision and
then click TVision in the CG. When you click on TVision again, the source
from ToasterVision is removed from the CG display area and replaced with
the default background. 
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TVision updates automatically when you change the source for Main or
Preview in the Switcher. If you change the channel for your Main input in the
Switcher, that change is reflected in ToasterVision. Therefore it is also
reflected in TVision on the CG.

GENERAL BUTTONS ON THE CG
General editing buttons sit across the top of the panel. Cut, Copy, Paste,

Delete, Undo, and Redo work on your selected item. 

Figure 14.3. Common buttons for Cut, Copy, Paste and so on.

• Cut removes the item from the display and places it in clipboard
memory until you paste it again. 

• Copy retains a copy in the display and places a copy in memory. 

• Paste places the item that you cut or copied. 

• Undo will undo your last action, and Toaster CG supports unlimited
levels of undo. 

• Redo will redo any actions that you just undid. 

You can also use familiar editing shortcuts like CTRL + X to cut, CTRL + C
to copy, and CTRL + V to paste. 

SAVING AND EXITING THE CG
At the top left of your panel is the File button. Here you have options to

create new CG pages, open, add files, and save pages, images, or projects.
CG pages are saved as *.cg files, and when you choose Save Project you
save all pages in the CG. When you choose Add Files, you can add a saved
CG page or project to your current project. When you choose Save Current
Page, then you save only the active page in the CG. 

You can save the current page in an image format as well (gif, tga, jpg, tif,
bmp) by choosing Save Image File. The elements on the page become one
image and you can no longer edit them separately when you load the image
file.

When you save CG as an image, Video Toaster saves the entire page. That
means that if you save a scroll page (discussed later) as an image, the CG
creates a long image to encompass every element on the page. When you
load this oversized image in the work area, it is initially squashed. But when
you edit the image from the edit panel, the original dimensions of the image
are restored.
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You exit the CG from the File button, by choosing Exit, or you can click
on the small X in the top right corner of the panel.

TOOLS FOR CG
The CG tools are the column of buttons on the left side of the CG panel;

you select from these buttons to create CG elements. Beside the tool
buttons are variations that you can apply when you create your objects. We
will discuss how to change the color and other attributes of these objects
later in the chapter.

Figure 14.4. The Tools for creating text and objects

TEXT IN CG
The Text button lets you create words and sentences, which  are

commonly referred to as titles in the world of video. Beside the Text button
are options for justifying your text (left, center, or right). These justifications
are similar to those you encounter in word processing. 
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Figure 14.5. Top:Text tool button. Bottom: Right-aligned text coming from the I-beam cursor

When you choose a justification option and begin typing, the text justifies
around the origin of the cursor. Left justifies the first letter of every line of
text as though the cursor is a left margin. Right justifies the first letter of
every line as a right margin. The center option centers every line of text
around the position of the cursor.

To create text

1 Choose the Text button.

2 Choose the alignment for your text. 

3 Click once on the I-beam and type the text from your keyboard. 

The text appears in the display, following the I-beam cursor. 

Text and the Keyboard

Note that when you create CG titles, a line of text remains one object.
When you hit the ENTER key to move to a new line, that new line is a separate
object. Any text—whether it is a single letter, a single word, or an entire
line—will be a separate object once you hit the ENTER key. However, the
alignment you choose applies to the objects as a single entity.

You can use the END and HOME keys on your keypad to navigate to the
beginning and end of text lines. The arrow keys on the keypad let you move
one character or one line at a time. The DELETE key lets you delete lines or
characters.

Importing Text

You can import text from word processing software, such as Microsoft
Word, and use it for scrolls or crawls. Choose File > Open and the CG will
load the text.
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BOXES IN CG
The Box button lets you create squares and rectangles. You can create

boxes as outlines, or as solids. They can serve as layering elements for your
titles, or as decorative elements on their own. 

Figure 14.6. Top: Box tool button. Bottom:An outline box and a solid box.

To create a box

1 Click on the Box button.

2 Choose the icon for outline or solid.

3 Place your mouse cursor in the display where you want the element to
begin.

4 Drag your mouse out to the size that you want. The Character Generator
creates your shape in real-time.

To adjust a box after you create it

1 After you create the box, click in the work area. Then hold the SHIFT key.
You see anchor points appear at the corners of the box.

2 Still holding the SHIFT key, place your mouse cursor in an anchor point.

3 Drag in any direction to change your shape. 
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POLYGONS AND SPLINES IN CG
With the Polygon option, you can create a polygon outline, a polygon

solid, or you can build an open path. 

Figure 14.7. Top: Polygon tool button. Bottom:An outline polygon and a solid polygon.

To use the Polygon tool

1 Click on the Polygon button and choose one of the polygon variations.

2 Click in the display wherever you want the shape to begin. 

3 Click around the display to build your shape.

4 When you make the shape you want, double-click to end the polygon.

To adjust a Polygon after you create it

1 After you create the shape,click in the work area. Press and hold the SHIFT

key. You see anchor points appear at the corners of the polygon.

2 Still holding the SHIFT key, place your mouse cursor in an anchor point.

3 Drag in any direction to change your shape. 

The Spline option works like the Polygon option, except you create
curved objects.
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LINES IN CG
The Line element has no variations. To modify attributes for the line

element (and the text and shape elements as well), you must go to the Edit
panel, discussed later in the chapter. You often see lines used as decorative
or emphatic elements with titles.

Figure 14.8. Top: Line tool button. Bottom: Lines and a dot.

To create a line

1 Choose the Line button.

2 Click in the display where you want the line to begin.

3 Drag out the line to your desired length. 

You can make vertical, horizontal, or diagonal lines. You can also adjust
the line after you create it by clicking in the work area, then holding the
SHIFT key and dragging on the anchor point. If you click once with the Line
tool, you create a dot.

CIRCLES, PIES, AND ARCS IN CG
The Circle button lets you create circles and ovals, and it lets you make

partial circles and slices. You can build these elements as outlines, or as
solids.  

Figure 14.9. Top: Circle tool button. Bottom:A solid circle and an outline circle.
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To create a circle

1 Click on the Circle button.

2 Choose the icon for outline or solid.

3 Place your mouse cursor in the display where you want the element to
begin.

4 Drag your mouse out to the size that you want. The Character Generator
creates your shape in real-time.

To adjust a circle after you create it

1 After you create the box, click in the work area. Press and hold the SHIFT

key. You see anchor points appear at the curves of the circle.

2 Still holding the SHIFT key, place your mouse cursor in an anchor point.

3 Drag in any direction to change your shape.

To create a partial circle

1 Click on the Circle button.

2 Choose the icon for a partial circle.

• The first icon cuts from the radius of the circle. 

• The second icon cuts from the perimeter of the circle.  

3 Place your mouse cursor in the display where you want the element to
begin.

4 Drag your mouse out to the size that you want. The Character Generator
creates your shape in real-time.

5 A vector line appears after you drag out the shape. 

• Drag clockwise to cut away from a full circle. 

• Drag counterclockwise to build a partial circle.

You can adjust the arc on the Arc/Line tab, described later in the chapter.
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IMAGES IN CG
The Image button lets you load a frame, or still image, into the CG as a

bitmap. Any logo or other graphic element can easily be incorporated into
your CG pages as a bitmap with a transparent matte. (If you want to place
video in the background of your CG work area, you use the TVision button,
discussed earlier.)

Figure 14.10. Top: Image tool button. Bottom:An image loaded in the CG.

To load an image

1 Click on the Image button; this launches the File Bin.

2 From the File Bin, browse to the directory that contains your image file
and click the Open button. The image is loaded in the CG work area.

You can load images that are stored in the following formats: bmp, gif,
jpg, png, tga, and tif.

If you created the image with an alpha channel, the CG maintains your
alpha information. If you want to make a solid background transparent, you
can do this by using the Chroma Keyer or Cross Keyer (discussed in the
Chapter 16: Keying), but it may be easier to change the background in the
paint program in which you first created it.

The image is an independent element, so you can select it with your
mouse and move it around the CG work area. Because it is an element that
you can select, you can Cut, Copy, and Paste an image. From the Transform
region, you can rotate and scale an image as well. (Though you should be
careful because scaling affects the detail and quality of an image.)
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To remove the image from the work area, select its bounding box and
choose the Delete button at the top of the panel.

TRANSFORMING CG ELEMENTS
Once you’ve created a CG element, you may need to move it or scale it a

little. You choose the Modify button to make any of these changes. 

MOVE, SCALE, AND ROTATE WITH MODIFY

With the Modify button active, you can move, scale and rotate your CG
objects. The default actions when you click on the Modify button are move
or scale. 

Figure 14.11. Transform buttons and text sample

To move an item

1 Click on the Modify button and select the object you want to adjust. A
bounding box appears around the item.

2 Place the mouse cursor on the item, not on the edges of the bounding
box. Drag the item with your mouse in the direction that you want to
move.

To scale an item

1 Click on the Modify button and select the object. A bounding box with
handles appears around the item. 

2 Place the mouse cursor at the edge or corner of the bounding box.

3 Drag the edge or corner to the size that you want. 

Figure 14.12. The scale option used on the left top corner of text
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Pulling a corner scales the item up, and pushing a corner scales it down.
If you drag an item only from the top or bottom, you scale the item
vertically. If you drag an item from only the left or right side, you scale
horizontally. You can also make a mirror image of an object by scaling past
the opposite side.

To rotate an item

1 Click on the Modify button and select your object. A bounding box with
handles appears around the item. 

2 Hold the SHIFT key, grab a corner of the item and rotate by dragging in the
direction that you want to rotate. (The arrows will change from up/down
arrows to curved arrows.) 

An item rotates around its center, regardless of where you grab it. If you
select more than one object, you rotate all objects around the center of the
last one selected. 

Figure 14.13. Rotate text

NOTE

When Lock is activated (on the Text tab), the CG restricts the mouse to
the safe area when you modify objects.

ITALICS FOR CG TEXT

The Italic option lets you apply a slant to text.

To adjust italics

• Click on the Italics button. Grab the text’s bounding box by a corner and
drag in the direction that you want to apply the slant. 

Figure 14.15. Italics on text
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BORDERS AND SHADOWS IN CG
The Border and Shadow options apply an outline or a drop-shadow to

your text or object, respectively. These properties can be controlled
precisely on the edit tabs at the bottom of the panel, which will be
discussed later in the chapter.

To adjust the border

• Click on the object then drag out the border’s thickness. (More attributes
are discussed later.)

To adjust the Shadow

• Click on the object then drag out the shadow’s position. (More attributes
are discussed later.)

As stated earlier, you can use editing shortcuts when you Modify. Also
notice that you can grab all objects by clicking your mouse in an empty area
of the display and dragging out a bounding box around the items. Then you
can apply global changes, like Rotate, to the entire group. To unselect an
item, or your group, click in an empty area of the display again.

MOTION FOR CG
Scrolling text is often used for credits at the end of a program, while

crawling text is often used for alerts and similar attention-grabbers. When
your text scrolls, you see the words move vertically from the top of the
screen to the bottom (or vice versa), and when your text crawls, the words
move horizontally across screen. 

Figure 14.16. The Motion options

In the Video Toaster [2] CG, you create your text and then assign a
moving page by choosing either scroll or crawl. When you click on either
button, you see a preview of the scrolling or crawling action. You can stop
the preview by clicking the button again. 
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DIRECTION

Figure 14.17. The Behavior menu

• Up Scroll moves text vertically up the page. 

• Down Scroll moves text vertically down the page. 

• Left Crawl moves text horizontally across the page from left to right. 

• Right Crawl moves text horizontally across the page from right to left. 

BEHAVIOR

Figure 14.18. The Behavior menu

• The Over option tells the CG to scroll or crawl the page once, then stop
when the page has left the screen.

• The Stop option tells the CG to scroll or crawl the page once and then to
hold on the last line of text. 

• The Loop option tells the CG to loop the page continuously.

• The Loop add Frame option tells the CG to loop the page continuously
and to place a blank frame between each loop iteration. 

NOTE

When Lock is activated (on the Text tab), the CG locks the editing
window so that active video does not scroll or crawl as you type text.

HINT

Type “End” or another indicator at the end of your scroll so that you can
verify when the scroll leaves the screen. You can make the “End” text
invisible by activating the Do Not Render option in the Text tab.

C H A P T E R F O U RT E E N : C H A R AC T E R G E N E R ATO R 14 .15



SPEED CONTROL FOR CG
Beneath the motion options, you have speed controls for your moving

pages. The drop menu gives you ten default speeds to choose, from 1
pixel/frame up to 50 pixel/frame. These speeds are variations of slow,
medium, and fast. 

To precisely control your page speed, use the Time/Speed drop-menu.
Choose the Time option to define speed in seconds. Use the Speed option to
define speed in frames. You enter a value from your keyboard into the field
adjacent to the menu, or you can use the mini-slider to scrub to a speed. 

OUTPUT FOR CG
The buttons below the speed controls give you options for sending your

CG creations as output. You can wait for a Cue, which is a signal from the
Switcher, you can Go to the Switcher’s Main bus, or you can send the CG
straight to Program Out and bypass the Switcher altogether.

Figure 14.19. Options for sending CG to output

CUEING CG FOR THE SWITCHER

Cue sends the CG to the Switcher, where it turns on the DSK and
activates Program Out. Cue also sets the CG in an available Switcher
channel. However, the CG will not do anything until you hit Go. 

GO

Go launches or pauses your CG motion on the Switcher—it is the button
you select when you want CG action to start and end immediately. When you
complete your CG text or graphics, you can click on Go and by default, the
CG action runs in the DSK. If you want CG to run from a channel in the
Switcher, you must activate the Main bus for that channel.

PROGRAM OUT

Program Out is the button that you select when you want to bypass the
Switcher and send the CG directly to output. Again, you make your
adjustments, then, click on Program Out. You see the CG appear on any
output monitors that you have attached, and if you are recording, the CG is
sent to the recording device.
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PAGES AND LAYOUT IN CG
Layout gives you a diagram view of how your elements are positioned

and the Pages are thumbnails of your available CG pages. Alright, so
mucking about with diagrams and pages is dull work, but it’s necessary. You
need a good foundation to support your inventive ideas. 

LAYOUT TAB

By moving elements in the diagram, you change their layering on the CG
screen. For example, you may have a bunch of lines of text (which you
remember are separate elements, of course) and you want to reorder them.
Rather than messing with selecting them in the work area, you can move
your elements in this diagram view. 

Think of this diagram as layers in a paint program. If you choose the
bottom row of text and move it to the top, then you place the text in the
background. The last item in your list on the Layout tab is the foremost item
in terms of layering. 

Figure 14.20.The Layout tab with the schematic view of CG objects.

CG Layout Diagram

The diagram shows the name and type of object (e.g., text, box, etc.). You
select the object name and it is highlighted in blue. When you move the
object, a line appears at your new insertion point. The layout diagram helps
you select an object, especially if you have a lot of overlapping objects, and
move it to the depth you want.
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Layout Layers

Layer options give you control over the depth of your objects in relation
to eachother. 

• The Front button places the selected object in the foreground of the
screen, so that it covers all other items. For example, if you used text in
a box, you’d place the text on the front layer so it sat over the box. 

• The Back button places the selected object in the background of all
objects in the CG work area. 

• The Up and Down buttons move objects one level front or back. For
example if you had a four shapes, and you wanted to move the third in
front of the second, you choose Up.

Layout Alignment and Spacing

The Align buttons let you align a group together when you choose
multiple objects; all objects will align based on the position of the last
selected object. 

NOTE

Do not confuse alignment with justification.Alignment positions objects
with a selected object, not with the margins of the page or the safe area.

• Left and Right align your objects with the left or right edge of the last
selected item. 

• The Top and Bottom buttons align your objects with the top or bottom
edge of the last selected item. 

• The Horizontal and Vertical options center the objects to the center of
the last selected item’s anchor on the X axis or the Y axis, respectively. 

• The Width and Height options apply only to text—they let you set the
text spacing along the X axis or the Y axis of a previously selected area.
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Space buttons let you adjust the amount of space placed horizontally or
vertically between each entry. 

• Use Horizontal space for objects that crawl across the screen

• Use Vertical space for items that scroll up or down the screen.

Groups in Layout

The Group option lets you group CG elements so that you can adjust
them together. With this option on you can define a group, and change the
color, size, or position, and so on, globally for every item in the group. You
would group items if you need to make identical changes to all of the items,
such as moving or scaling.

PAGES TAB

A screen full of text is referred to as a page. Whether a page is completely
filled with text, contains only one person’s name at the bottom, scrolls, or
remains static, it is considered a complete page.

CG Pages

A series of pages is often displayed in sequence, one after another, at the
beginning of a program. For example, the first page shows the title of the
program; the next page may include the sponsor’s logo; and the following
pages may give the names of the show’s hosts. Each of these individually
displayed graphic elements is considered a page.

If the page contains text that scrolls up the screen or across the bottom
of the screen, it is still a single element, a single page. The page is the
method employed to display video graphics—whether those graphics are
static or moving. Therefore, if you have to create one graphic for a title,
another for a station ID, and another of scrolling credits, you would create
each of the items on a different page. You would have three separate pages
of graphic elements.

The Pages tab is the area where you add, delete, and clone your pages.
When you choose this tab, you see a thumbnail view of the pages you have
created or loaded.  
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Figure 14.21. The Pages tab with thumbnails of CG pages.
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Add, Delete, and Clone CG Pages

You add pages by clicking in the open work area, or by clicking the Add
button. You delete pages by selecting a page and choosing Delete. You
clone, or copy, a page by selecting a page and choosing Clone. You can also
cycle through your pages by using the Back and Forward buttons. 

Navigate and Save CG Pages

When you work on a page in CG and you want to switch to a different
page, you click the Pages tab. Then you select the page that you want to
work on. Use the Back and Forward buttons to navigate through your
pages. Above the Pages tab, you see a Page Number field that tells you
which page you have selected. Enter a number in the Page Number field to
jump to a specific page. The CG work area immediately displays the page
you choose. 

Remember that when you choose Save Project, you save all of the pages
in the CG project. You can, of course, save a separate page by itself by
choosing Save Current page from the File menu.

CG PROPERTIES
In this tour of the CG panel, you may have noticed that you’ve created

elements that are always white. By now you probably want to add some
style to your titles and graphics and change the color and attributes. The
options for beautifying your CG elements reside in the properties tabs at the
bottom of the panel.

CG supports TrueType fonts and you can apply effects like borders,
shadowing, variable transparency, and gradients on text and shapes. You
can also adjust your text graphically with real-time sizing, kerning, and
rotation. 

PREVIEWS OF CG STYLES

The preview area to the left of the properties tabs lets you see your
changes in real-time. 

TEXT PROPERTIES

You can change the font for your text and you can change the text’s many
attributes, like size, spacing, and rotation. When you work on selected text,
you see your changes in real-time in the CG work area and the preview area.
If you haven’t created any text, you see your changes in the preview area
and the next string of text that you enter will use your new attributes.
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Figure 14.22. The Text tab with options for changing the appearance of CG text

Text Direction

Direction places characters in a certain order, so that you can set text to
read it in the following ways: 

• horizontally from Left to Right (English and European); 

• horizontally from Right to Left (Arabic or Hebrew);

• vertically Up to Down (Japanese, Korean, or Chinese);

• Do not render makes an object invisible at output.

Font and Size of Text

Change the Font by choosing a font name from the drop menu. To change
font size, you enter a point size in the Size field, or you can use the mini-
slider to adjust the size. When you enter a size in the Size field, you
constrain the text proportions, so you change both the horizontal and
vertical size. The Spacing field lets you adjust the amount of space between
the letters in your words.

Italics and Rotation of Text

You can create faux italics by entering a skew value in the Italics field.
Watch the font preview to see the degree of slant you apply. Rotating text is
just a matter of entering or dragging a value in the Rotation field.
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Width and Height of Text

The Width and Height fields let you stretch your text along the X or Y
axis. Enter a number in the X field to stretch text horizontally; enter a
number in the Y field to stretch vertically. Remember that you can
graphically adjust any of the preceding settings, from Size to Height, in the
main interface by using the Modify button.

Text Color

Change the color of the text you entered by clicking on the button below
the Color icon. This launches a Color Picker panel where you can choose a
color; the text updates immediately. Other Fill settings override any Color
settings.

LOCK

The Lock option will lock the editing window to a single page so that the
active video does not scroll or crawl as you type text. When the Lock is
activated, the CG also restricts the mouse to the safe area when you modify
objects.

BORDER PROPERTIES

The Border refers to inner and outer borders that surround your text. 

Figure 14.23. The Border tab with options for changing the appearance of CG borders

Border Type

The Type option lets you define the kind of edges to apply to the border.

• Off completely removes the Border effect from your text, so you can
have text with no border or outline at all.

• Round gives you rounded edges.
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• Miter gives you square edges.

• Bevel shears the corners from your letters by 45 degrees. 

• Size increases or decreases the edge around your text—that is, you
make the edge thicker with a high value or thinner with a low value. 

Border Fill

The Fill setting gives you gradient options if you choose different colors
for Inner Color and Outer Color. 

• Round makes a linear gradient, like a color wheel.

• Ling makes a radial gradient, like a bull’s eye.

Rotation lets you enter a value to rotate the angle of the Round fill. So, if
you use a Round Fill and you set Rotation to 90, you get a gradient that
moves from the Inner Color at the bottom to the Outer Color at the top. 

SHADOW PROPERTIES

The Shadow tab provides several choices for shadow effects. 

Figure 14.24. The Shadow tab with options for changing the shadows on CG objects

Shadow Type

The Type option lets you define the kind of shadow: 

• Off sets no shadow. If you don’t want to apply a shadow to your text or
object, choose Off.

• Drop applies a hard drop shadow behind your text, which is a
duplicate of the text offset from the original. 
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• Soft is similar to Drop except the shadow color is blended with the
background and the edges are blurred. 

• Cast creates a hard shadow that originates from the base of the original
text, like a shadow cast on an object by the sun. 

Softness lets you apply a blur amount to a Soft shadow for a softer edge.
Use higher values to get softer shadows with more blur. Italic gives you
independent italics for the shadow, which is separate from the object’s
italics.

Shadow Offset

You can adjust the offset of the shadow by using X and Y Position. These
fields let you enter a numerical value to move the shadow. The X Position
moves the shadow horizontally and the Y Position moves the shadow
vertically. 

You can also adjust the shadow offset graphically in the CG interface.
From the Transform region, click on Shadow. The CG sets a bounding box
around the Shadow element, and you can grab it and move it around. 

FILL PROPERTIES

The Fill tab offers a choice of gradients and textures that you can apply
to your text or object. 

Figure 14.25. The Fill tab with options for changing the fill in CG objects 

Fill Range
The Range field specifies how you want the fill applied to the text:

• Character applies the fill separately to each character in your text

• String applies the fill across the entire word or sentence as a unit.

C H A P T E R F O U RT E E N : C H A R AC T E R G E N E R ATO R 14 .25



Fill Type

When you choose a Type, you see a preview in the Gradient display at
the bottom of the panel. You can choose the following types of Fills:

• Solid is one solid color.

• Rainbow is the entire spectrum as a linear gradient.

• FourCorner is a gradient with different colors in each corner that blend
toward the center.

• Round is a gradient that radiates around the center in a clockwise
direction, like a color wheel.

• Ling is a gradient that radiates from the center to the perimeter in a
series of concentric circles, like a bull’s eye.

• Texture uses a loaded image as a fill.

Fill and Gradient

You can tweak the Fill gradient to suit your needs or create a new one.
The different Node buttons below the preview refer to the nodes within the
gradient. The controls available let you Delete, Scale, Shift and Clear All
nodes. 

When you Clear All, the gradient returns to the default Rainbow. The
Shift option shifts selected nodes together to the left or right. Scale
compresses or expands selected nodes.

The default mode for the node is Add, so if you click around in the
preview without selecting a control, you will add nodes. When you click in
the preview, you add a node, and the Color Picker panel pops up for you to
choose the color that you want to insert. You can change the color of an
existing node by clicking on the swatch in the base of the node. This action
launches the Color Picker where you choose the new color.

The Rotation setting lets you change the angle of the FourCorner
gradient. You can see where the new value falls in the preview to the left.

The Solid Fill Color option lets you change the color applied with the
solid fill.

Beside the Delete Node button there is a button with an arrow, which is
the Gradients menu. You can choose gradient presets from this menu. Add
your own gradients to this menu by choosing the Add option at the top of
the menu. The CG creates a thumbnail version of your gradient and places it
in the list.

14 .26 V I D E O TOA S T E R [2 ]



Texture and Images as Fill

Use the Texture option in the Fill drop-menu when you want to load an
image as the Fill. Click on the Image button to load an image from your hard
drive or a disk. 

The image file must be stored in one of these formats: bmp, png, tga, tif,
gif, or jpg. When you load an image, a thumbnail preview appears in the
display window at the left of the Edit panel. You can rotate and size your
image in that thumbnail image. You can use Range to apply the image
separately to each character (Character) or to apply the whole image across
the string of text (String). 

ARC/LINE PROPERTIES

The Arc/Line tab provides several choices for adjusting the structure of
objects that you create with the geometric tools: Box, Polygon, Line, Spline,
and Circle.

Figure 14.26. The Arc/Line tab with options for adjusting lines and circles 

Joint Type

Joint Type applies only to the borders of Boxes, Polygons and Lines:

• Round gives you rounded joints.

• Miter gives you square joints.

• Bevel shears the corners of the joints at 45 degrees. 

• Size increases or decreases the edge of the object—you make the edge
thicker with a high value or thinner with a low value. 
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Ending Type

Ending Type creates the style for the ends of your lines and splines:

• Butt gives you square ends.

• Round gives you rounded ends.

• Projecting gives you sharp ends.

Arc Start and End

Arc Start and Arc End let you adjust arcs and circles by entering
numeric values. Arc Start is the angle where you want the Arc to Start and
Arc End is where you want it to end. The value you enter must be between 0
and 360 degrees.

For example if you wanted to enter a precise value for a half-circle, you
create your circle or half-circle first and then you enter the value 0 in Arc
Start and 180 in Arc end.

Circle Width and Height

The Width and Height fields let you adjust the area of the arc and circle
elements, so that you can make them into oval shapes.

Line and Border Thickness

The Thickness setting applies to all geometric objects. Increase the value
of this setting to make a line or spline thicker, or to give the borders of
unfilled objects thicker lines.

CG PLAYER
The CG Player gives you an alternative and smaller CG interface where

you can load and play CG files, and change a few options. You load files by
clicking on the File button and choosing Load or Add Files. You can save
changes to the files by choosing Save Project or Save Current Page.

Remember that when you save a CG file, you save all pages in the project.
So when you load a CG file into the CG Player, you load, and therefore play
all pages in the file.

Sending CG to the Switcher from the CG Player uses some of the same
buttons as the CG. You are limited to Cue and Go. You can place the CG
Player on the Preview bus and use Cue to add the signal to the Switcher,
then hit the Go button to play immediately. 

You can jump to any page by typing the page number in the text box at
the bottom-right of the panel.
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The options on the CG Player are limited to Direction, Behavior, and
Speed. So you can choose whether your file scrolls up or down, crawls left
or right, and how fast these actions happen. These three options are also
saved with your CG pages. To affect any other aspect of the CG, such as its
overall appearance, you must work in the main Character Generator. You
can find more information about Direction, Behavior, and Speed earlier in
this chapter.
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TASK: CHARACTER GENERATOR
Developed by Billy Pecora

CREATE A TITLE PAGE

The Title Page is a CG page that presents the title of your program or
introduces different sections of your program.

Use a loaded image

In this tutorial you will add a still image and place three lines of text over
it. Each line of text has its own style.

1 Start a new project by choosing File > New. This starts a new session
without saving anything you were working on.

2 Click the Image button and load the CG_2PALMSINSILHOUETTE.JPG from the
CONTENT\VTIMAGES directory. 

NOTE

Usually, you size your image in a paint application before you load it into
CG.You can size an image within the CG, but the CG is more efficient if
it doesn't have to resize the image every time the page is loaded. Larger
pictures will take more CPU time to move and edit.
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3 Drag the image to the inside of the safe area: set it to fill the left side of
the screen. 

4 Add some text; click on the Text button and select the center alignment
option.
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5 Click on the I-beam cursor and drag it to the top right half of the Safe
Area. Drag the cursor until the top aligns with the top of the trees and it
is centered in the safe area. 

Type ‘NewTek’ and hit ENTER; 

Type ‘Video Toaster’ and hit ENTER; 

Finally type ‘[2]’ and hit ENTER.
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6 Group the text together so you can move the entire group as a unit. Go to
the Layout Tab and select all lines: click on the first line of text, hold the
SHIFT key, and click on the last line of text. Then click on the Group
button at the bottom of the Layout tab. 
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7 Select the first line of text in the Layout Tab, then click on the Modify
button. Though you grouped the text, you can still select individual
objects. CTRL-click to select the Video Toaster line also.

8 Choose a style from the Styles bin: click on the white text with blue
border. The text automatically updates in the work area. On the Text tab,
set the Size to 60.

14 .34 V I D E O TOA S T E R [2 ]



9 Adjust the Style a bit. On the Border tab, reduce Size to 3. 

On the Shadow tab choose Drop, set both X and Y Position to 4. For
Color, choose a dark gray.

10 Add this alteration to the Styles bin for future use. Click on the Add
button below the Styles.  

11 Select the last line ‘[2]’ and choose the style with black text and the small
white to light blue border. Set the Size to 96 in the Text tab. 

C H A P T E R F O U RT E E N : C H A R AC T E R G E N E R ATO R 14 .35



12 Center everything with the Align function on the Layout tab. Select the
text lines—choose the 'VideoToaster' line last. VideoToaster's bounding
box should be the brightest, so the Align function is based on this line of
text. Click on the Horizontal button and all text centers with the
‘VideoToaster’ line.

13 Select only the [2] and use the down arrow key to nudge it down until it
no longer overlaps the line above it.

14 Select the group by clicking on the word Group in the Layout tab. Then
click the Modify button and move the group into the upper right quad of
the screen.

15 Now is a good time to save your masterpiece. File > Save.
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CREATE A LOWER THIRD

The Lower Third usually places the name of a person or location at the
bottom of the screen. This is also where most crawls occur when the
National Weather Bureau issues a severe weather advisory.

1 Create a new Page by clicking under the current page in the Page tab.

2 Create two lines of Text: “Video Toaster [2]” and “www.newtek.com.” Left-
justify the text and set the size to 48, if it isn’t already.
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3 Choose Modify and apply the blue fill with yellow border to “Video
Toaster [2].” Then apply the plain text style to “www.newtek.com.” and
change the Color to a pastel purple, change Size to 36, and change
Spacing to 3.0.

4 Move the “www.newtek.com” and “Video Toaster [2]” to the bottom of
the safe area so that the “www.newtek.com” rests on the bottom edge.
Leave a bit of space between it and “Video Toaster [2].” Move “Video
Toaster [2]” to the left edge of the safe area.
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5 Create a background bar for “Video Toaster [2].” Select the Line tool and
draw a line under “Video Toaster [2]” that stretches from the left edge of
the safe area to the vertical divider.

6 Click on Modify and apply the plain text style from the Styles bin.

7 Under the Arc Line tab, set the line’s Thickness to 15 and its Ending
Type to Round.

8 In the Fill tab, set the type to FourCorner and delete all but the first three
nodes and the last node in the gradient window.  
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9 You will change the colors of the gradient. Select the middle-right node to
launch a Color Picker: click on a nice burnt orange or orange brown. The
node updates with the new color. Click on the right node, and find a nice
orange; do the same for the first node. Click on the last node to apply the
same orange. You should now have a gradient that changes from orange
to a darker browner orange then back to orange. Choose the middle
nodes again and set the Alpha to 123 so the brown becomes semi-
transparent as the bar travels from orange through brown. 

10 Back in the Fill tab, set the Rotation to -220.
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11 Scale the line by pulling the right edge until it goes past “[2].” Then on
the Layer tab, choose Back to put the line behind the text.

12 Save it! I think I hear a black out coming!

CRAWLING THE LOWER THIRD ON SCREEN

Use the motion settings to move ‘www.newtek.com’ across the screen.

1 Continue from the previous task.

2 Select “Video Toaster [2]” and the gradient bar. Under the Text tab,
activate Lock to keep the selected items stationary.
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3 Set the motion Direction to Left Crawl and set the motion Behavior to
Stop. The text will enter the screen from the right and stops when it gets
into position. 

4 Click the GO button to test the motion.

5 Adjust the speed controls to make the Text enter quickly.

6 Save your creation.

CREATE A SCROLL

Scrolls are used most often to roll the credits at the end of a program.

1 Create a new Page by clicking under the current page in the Page tab.

2 Select the plain style from the Styles Bin.

3 Select the Text tool and set the alignment to Right Justify. 
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4 Position the I-beam cursor on the right edge of the safe area and type in
text. The edit window will automatically scroll down as you type.

Video Toaster’s

Character Generator

is easy to use

The CG also 

is equally delightful 

to the user’s eyes.

What else would users

expect from an alien

technology, right?

5 Group the lines together on the Layout tab.

6 In the Layout tab, select all text, then click on the longest line to make it
the anchor. Click on Left under the Align group. Click on the Group in the
hierarchy window to grab the lines as one unit. Choose Modify and move
the group to the center line.
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7 Let’s say your client now wants the text centered in the middle of the
page. No problem, you can edit the text very much like editing in a word
processor. Choose the Text tool and click on the first line of text. 

• Use the END and HOME keys on your keypad to navigate to the beginning
and end of a line. 

• Use the arrow keys on the keypad to move one character or one line at a
time. 

• Use the DELETE key, you guessed it, to delete. 

Let’s remove the ENTER and make our text lines longer. Make your text
look like the text below:

Video Toaster’s Character Generator is easy to use

The CG also is equally delightful to the user’s eyes.

What else would users expect from an alien technology, right?

8 After you edit the text, select all lines and use the Horizontal Align on
the Layout tab to center them. Then on the Text tab, change Size to 18. 

9 Back on the Layout tab, choose Group and then in the Transform area at
the left of the panel, choose Modify. Position the group in the center of
the screen.
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9 Set the motion for your text: for Direction choose Up Scroll, and for
Behavior select Stop. Set Time to 15.

10 Test the motion by clicking the Go button. 

11 Now you can use the scroll with the Switcher: Press Cue to make the
scroll available and click Go when you are ready.

CREATE A PAGE BUILD

Page builds are often used for corporate presentations; a session of
bullet points are seemingly added to each page. You accomplish this effect
by creating a series of CG pages that add bullets to each consecutive page. 

1 Create the first page. You will make a gradient fill box in the background
and a title bar in the upper right hand corner of the safe area.

Cover the safe area with a filled box and use the following Fill properties:
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Type: FourCorner; Rotation: -145; Color the first four nodes: light purple,
dark blue, light purple, and green. You should get a nice teal to lavender
background. You may need to delete extra nodes and use the Shift option
to move others.
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2 Next, add the title bar. Draw a line that fills the top left quad of the safe
area. Choose Modify and give your line the following properties:

Ending Type: Round; Thickness: 50, Color: medium blue; Fill Type: Solid;
Shadow: Off; Border Type: Round; Fill Type: Round; Border Size: 5;
Border Rotation: 308; Inner Color: white; and Outer Color = dark blue.
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3 Select the Text button and add the title text. Choose a font and type "VT
[2] Points." Select Modify and size the text to fit in the title bar. Give the
text the following properties:

Font color: White; Border Type: Round; Border fill: Ling; Border size: 3;
Inner Color: black; Outer Color: medium gray; no shadow.

4 With Modify still active, center the text over the title bar.

These elements create the back plate for your page.

NOTE

If you have more bullet points than will physically fit on one page,
clone the first page before you add the first bullet point and use
the clone for additional points.

5 Select the Text button and type "Less Work," for your first bullet point.
Left-justify this text to the vertical center line. Choose Modify and size up
the text a bit to take up more space on the screen. Choose the style with
white text, red border and blue shadow. Change the Shadow Softness to
5.0.
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6 Something is missing . . ah, yes, the BULLET. Choose the Text tool and
click in front of “Less Work.” On the Text tab, choose the Wingdings font
and hit the W key to get a diamond bullet.

7 Align the bullet by selecting both the bullet and the text line in the
Layout tab. Click on Vertical under Align and the bullet should move to
the vertical center of the text.

8 Now that you have the first bullet point, you should clone this page to
create the next. Under the Page tab, click on the Clone button to
duplicate the current page, then click on the newly cloned page to select
it.
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9 Choose the Text button again, click on “Less Work,” press the END key to
jump to the end of the text. Press ENTER to start a new line. Type “More
MONEY” for your second bullet. 

10 Select the bullet on the first line. Click Copy and then click Paste. The
new bullet is created over the old one. Your original bullet is still
selected, so move it down to the second line. 

11 As you did before, select the line of text beside the bullet and choose
Vertical align. Then select ONLY the two bullets—the top bullet should
brightest—and choose Horizontal align.

12 Repeat steps 8 and 11 to make bullet points for "More Toys" and "More
FUN."
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13 After you create your four bullet point pages, you can use them in a
project.

a. With the Switcher: Choose CG on the DSK. You can then fade up the
first page and when you click on each page in the CG, the pages are
displayed on output. Each new bullet point will snap on screen when
you click on the page.

b. To transition between these pages with the Switcher, save each page
separately. Add the saved pages to two DDRs or to two CG Players,
alternating their order. Then you can transition between the two DDRs
or CG Players to add effects.

c. With ToasterEdit: save each page out individually, add it to your
project and use effects to transition to each additional page.
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